Actualizar Debian Etch a Lenny


Debian 5.0

El día 14 de Febrero del 2009 se lanzó la nueva versión de Debian, entonces decidí actualizar la versión del Debian que uso. Así que aquí les pongo los pasos para actualizar el Debian.

Primero para actualizar el Debian tenemos dos opciones, una es instalar nuevamente el Debian con los CD’s conseguidos previamente de http://www.debian.org/distrib/ , la otra es actualizar el Debian que ya poseemos. Yo mostraré el segundo ya que es lo que hice.

1.- Cambie en mi sources.list ( archivo /etc/aqt/sources.list ) modifique lo que decía etch a lenny, quedándome algo similar a esto:

deb http://ftp.br.debian.org/debian/ lenny main
deb-src http://ftp.br.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib

2.- Luego de eso abrí la consola y escribí como root “apt-get update” (sin comillas) y al final me salio este mensaje (lo mismo salé con el synaptic):

There is no public key available for the following key IDs: 4D270D06F42584E6

3.- Entonces luego buscando en internet encontré que la solución para esto era agregar la llave publica solicitada, escribiendo ahora esto:

gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 4D270D06F42584E6

Saliéndome este mensaje:

gpg: requesting key F42584E6 from hkp server wwwkeys.eu.pgp.net
gpg: key F42584E6: "Lenny Stable Release Key " not changed
gpg: Total number processed: 1
gpg: unchanged: 1

4.- Luego agregamos la llave encontrada en el servidor con esto:

 

apt-key add /root/.gnupg/pubring.gpg

5.- Posteriormente de que nos sale un mensaje que dice “OK”, ya procedemos a hacer un “apt-get dist-upgrade” para actualizar los paquetes de nuestra PC.

apt-get dist-upgrade

6.- Una vez terminado los pasos anteriores ya pueden disfrutar de su nuevo Debian Lenny, algunos configuraciones cambiaron, caso mi Eclipse, Xmms (ahora Xmms2) y Gimp (desapareció :-s), pero solo es cuestión de dar pequeños arreglos, espero les sea de su agrado :D.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s